没事别瞎升级dovecot,好像会破坏现有的邮局运行!

当看到这篇水文章的时候由于由于在前一篇文章中提到的将自建邮局的一些程序成功升级而飘飘然了手贱的执行yum install打算把dovecot、postfix等都升级一波的。。。。

本来在虚拟机里面执行yum install已经出现了dovecot的一些配置文件的报错但是由于在前面提到的安装PHP8.0后WebMail无法打开了就没得测试是否有影响了,看到了这个“警告”我还是在自建邮局哪里执行了一波,还特意看看是否有dovecot、postfix相关的升级才按“Y”继续安装的。

升级到一部分就提示iptables的一些报错(和在虚拟机上面不一样),我只好取消YUM进程,然后看了下dovecot是有升级了可是也无法启动了,提示不支持“sieve”这个协议。

又不好把那个协议取消掉只好卸载新版本的dovecot(安装了两个新版本的dovecot了,卸载两次才没有),然后安装EwoMail 1.06版本里面的dovecot,再手动把脚本里面的相关操作收到执行一下,几经折腾很好dovecot已经能跑起来了,但是问题是在WebMail里面登录出现错误,连使用一些客户端软件都不能连上smtp、imap服务器之类的。。。。。。。。

暂时先不折腾了,还是重装大法回复邮局的功能先吧。。。。。。
本次运行了385多天的邮局只能重装系统了,1.09的Ewomail虽然支持了Centos8但是Centos8的安全支持好像比Centos7还要短了。。。。。。
14:36:08 up 385 days, 22:35, 3 users, load average: 0.00, 0.01, 0.07

现在只希望备份有效让我不再丢数据了。。。。。

补句题外话:
在虚拟机安装时不需要单独安装libaio,在VPS什么两次安装5.7(>=5.7.19)都需要手动安装一下yum install libaio,还有就是有个变量innodb_additional_mem_pool_size=2M已经不支持了。

备份还好有效,只是导入全部都是“未读”状态,好险是自己在使用而已,否则就。。。。。。

ChiuYut

2021年4月4日

发布者

ChiuYut

咦?我是谁?这是什么地方? Ya ha!我是ChiuYut!这里是我的小破站!